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Error Notifications

In Zene UI users can get notifications to inform them of various events, see Notifications for more details.

For this section, we will focus on the common error notifications that users may encounter when using Zene UI and how to resolve them.

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An example of an error notification - Input source is empty.

Error Input Source

Input source is empty.

Potential Cause

The input source is empty and trying to run the tool flow by clicking the Run button.

info

You can check the input source by expanding the Input tab in the Flow page.

Solutions

1. Add a tool to the input source.
  1. Go to the Flow page.
  2. Click on the Input tab.
  3. Click on the Add Tool button.
  4. Select a tool from the list.

For more details on how to add a tool to the input source, see Tool Flow

2. Open a project that has tools in the input source.
  1. Go to the Main menu.
  2. Go to either File server or File local.
  3. Select Open....
  4. Navigate to the project file.
  5. Click on the Open button.

For more details on how to open a project, see Main Area - Main Menu

Unable to grab frames from a Basler camera

No grab result data is referenced.

The buffer was incompletely grabbed.

Potential Cause

  • Performance problems of the network (GigE camera only)
    • Low bandwidth
      • e.g. using WiFi instead of Ethernet cable, 100Mbps instead of 1000Mbps, etc.
    • Dropouts
      • e.g. network congestion, bad cable, etc.
    • Problems in adaptors or switches hardware
      • e.g. bad cable, bad port, etc.
    • Unsupported hardware
      • e.g. low performance network card
  • Unconnected power cable
  • Unconnected data cable (USB3.0, Ethernet cable, camera link)
  • Problems with camera

Solutions

1. Re-run the flow.

This is the simplest solution, if the problem is caused by a temporary network issue, re-running the flow may solve the problem.

  1. Click on the Run button.
2. Check the camera connection.

In most cases, the problem is caused by the camera connection, for example, the power cable is not connected, the data cable is not connected, etc.

  1. Check the power cable.
  2. Ensure that the camera has power.
  3. Reset your camera by unplugging the camera and plug it back in
  4. Re-run the flow by clicking the Run button.
3. Check the signal integrity

Data of the camera is transmitted through a data cable, if the data cable is damaged or the signal is not strong enough, the data may be corrupted or lost. In most applications, the amount of data is large, so the data cable must have a sufficient bandwidth to transmit the data.

  1. Check the following from the camera to the server:
    • Not using WiFi connection.
    • Data cable is not damaged.
    • Data cable has a sufficient bandwidth.
      • For Ethernet cable, this must be at least Cat5e standard.
    • A single data cable length is not too long:
      • For USB3.0, the maximum length is 3 meters.
      • For Ethernet cable, the maximum length is 100 meters (50 meters in certain cases)
      • For camera link, the maximum length is 5 meters.
    • For GigE camera only, check the network connection:
      • Ensure that the switch:
        • is not damaged
        • has a sufficient bandwidth
      • Ensure that the network card:
        • is not damaged
        • has a sufficient bandwidth
      • Make sure that the network is not congested.
  2. Re-run the flow by clicking the Run button.
4: Increase inter-packet delay (GigE only)

For tasks that does not require high frame rate, you can increase the inter-packet delay to reduce the network bandwidth requirement.

  1. Go to the Flow page.
  2. Click on the Input tab.
  3. Select the desired Basler camera tool.
  4. Scroll down to the Network (GigE camera) section.
  5. Increase the GigE Inter-packet delay value (by 500-1000 ticks), this will decrease the maximum frame rate.
    • If the problem is not solved, increase the value again.
  6. Click Apply to save the changes.
  7. Re-run the flow by clicking the Run button.

For more details on how to change the inter-packet delay, see Basler Camera Tool

5: Acquire supported network hardware (GigE only)

If the problem is caused by the network hardware, you can acquire a supported network hardware. Change your Network Interface Card for the one supported by the Basler Performance Driver.